Opened 9 years ago

Closed 9 years ago

#762 closed defect (fixed)

default value for ScalingList

Reported by: sasai Owned by: bbross
Priority: minor Milestone:
Component: Text Version: D8 (K0030) v3
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

It is not clear which value should be set into ScalingList in the case that "scaling_list_enable_flag =1", "sps_scaling_list_data_present_flag = 0" and
"pps_scaling_list_data_present_flag = 0".

Change History (4)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 9 years ago by kazushi

It is suggested to add to the semantics of sps/pps_scaling_list_data_present_flag:

if scaling_list_enable_flag = 1 and sps/pps_scaling_list_present_flag = 0, default scaling_list as described in 7.4.2.4 shall be used.

comment:3 Changed 9 years ago by bbross

Ticket #787 has been marked as a duplicate of this ticket.

comment:4 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Fixed it by adding the following to sps/pic_scaling_list_present_flag semantics:

"When scaling_list_enable_flag is equal to 1 and sps/pic_scaling_list_data_present_flag is equal to 0, the default scaling list data is used to derive the array ScalingFactor as described in the scaling list data semantics 7.4.5.
[Ed. (BB): Check whether this description is still OK when the transform_skip_enabled_flag dependency issue (#786) is fixed.]"

This will be fixed in JCTVC-K0030_v5.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Kazushi Sato(Participant)
  • sasai(Reporter)
  • Woo-Jin Han(Subscriber)