Opened 10 years ago

Closed 10 years ago

#761 closed defect (duplicate)

Return type of getColRefIdx

Reported by: adarsh Owned by:
Priority: minor Milestone:
Component: HM Version: HM-8.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

The return type of the function getColRefIdx() in TComSlice.h, which is a member of class TComSlice, should be UInt. Currently, the return type is Bool, which could give erroneous value when the colRefIdx is more than one. The attached patch (w.r.t r2764, HM8.0-dev) has a solution.

Attachments (1)

ColRefIdx_Bugfix_761.patch (1.2 KB) - added by adarsh 10 years ago.
Bug-fix for return type of getColRefIdx()

Download all attachments as: .zip

Change History (3)

comment:1 Changed 10 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

Changed 10 years ago by adarsh

Bug-fix for return type of getColRefIdx()

comment:2 Changed 10 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #760.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Adarsh Krishnan Ramasubramonian(Reporter)
  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)