Opened 10 years ago

Closed 9 years ago

#328 closed defect (fixed)

(Actual version: H1003_dK) A few missing items

Reported by: hellman Owned by: bbross
Priority: minor Milestone: D8
Component: Text Version: D7 (I1003) d9
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

Page 26, Section 7.3.2.1 (seq_parameter_set_rbsp): scaling_list_enable_flag is missing a descriptor type. Should be u(1), I believe.

Page 63: log2_diff_max_min_transform_block_size: We have assumed a maximum transform size of 32x32 for several meetings now, but I guess that never made it into the draft. This section should specify that Log2MaxTrafoSize cannot be larger than 5. As written, it allows a 64x64 transform size.

Page 66: What is the range for cb/cr_qp_offset? Based on their use, I would think it would be like that of pic_init_qp_minus26 (-26 to +25 for 8-bit video).

Page 73: No range given for max_transform_hierarchy_depth_intra/inter. Seems like it should relate to log2_diff_max_min_transform_block_size

Page 76: No range given for beta_offset_div2 or tc_offset_div2. Equivalent variables in AVC had a range of -6 to +6.

Change History (8)

comment:1 Changed 10 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 10 years ago by bbross

Ticket #409 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by bbross

  • Milestone set to D7

The first one (scaling_list_enable_flag) and the second one (log2_diff_max_min_transform_block_size) are fixed in d7 HLS text.

The last three are still open.

comment:4 Changed 9 years ago by bbross

Ticket #542 has been marked as a duplicate of this ticket.

comment:5 Changed 9 years ago by pandrivon

Page 66 issue:
HM7.0 implements [-12;12] range limits (Cf. e.g. TAppEncCfg::xCheckParameter()). I think this is copy-paste from AVC however due to the way these syntax elements work/are derived (quite same as AVC) I cannot identify reasons to change this range except if market justifies it.

comment:6 Changed 9 years ago by bbross

  • Milestone changed from D7 to D8

comment:7 Changed 9 years ago by bbross

  • Version changed from D6 (H1003) dI/dJ/dK to D7 (I1003) d9

comment:8 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Pierre Andrivon(Participant)
  • Tim Hellman(Reporter)
  • Woo-Jin Han(Subscriber)