Opened 8 years ago

Closed 7 years ago

#1121 closed defect (duplicate)

HighestTid should be used instead of t_id for bumping

Reported by: rickard Owned by:
Priority: major Milestone:
Component: HM Version: HM-11.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

C.5.2.2 specifies among other things that bumping shall continue until the following condition becomes false:
"The number of pictures in the DPB that are marked as "needed for output" is greater than sps_max_num_reorder_pics[ HighestTid ]"

The HM code looks at sps_max_num_reorder_pics[temporal_id of the current NAL] instead of sps_max_num_reorder_pics[HighestTid]. This leads to pictures being output in incorrect order, for instance in this example with pictures listed in decoding order:

sps_max_num_reorder_pics[0]=0
sps_max_num_reorder_pics[1]=1
sps_max_num_reorder_pics[2]=2
sps_max_num_reorder_pics[2]=4 Note that 4 is needed here

IDR POC=0 t_id=0
TRAIL_R POC=8 t_id=0
TRAIL_R POC=4 t_id=1
TRAIL_R POC=2 t_id=2 HM bumps this picture too soon
TRAIL_R POC=6 t_id=2
TRAIL_N POC=1 t_id=3
TRAIL_N POC=3 t_id=3
TRAIL_N POC=5 t_id=3
TRAIL_N POC=7 t_id=3

Attachments (2)

PossibleFixFor1121.patch (2.0 KB) - added by rickard 8 years ago.
Possible fix
num_reorder_pics.patch (8.6 KB) - added by bheng 8 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

Changed 8 years ago by rickard

Possible fix

comment:2 Changed 8 years ago by bheng

In certain cases, the SPS pointer may no longer be valid at picture output time. This can cause the suggested patch to crash. Perhaps something like the revised patch would work?

Changed 8 years ago by bheng

comment:3 Changed 7 years ago by ksuehring

This looks like a duplicate of #1261?

comment:4 Changed 7 years ago by rickard

Yes, I believe the issue was fixed in r3863 as response to #1261.

comment:5 Changed 7 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #1261.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Brian Heng(Participant)
  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Rickard Sjoberg(Reporter, Participant)