Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1261 closed defect (fixed)

HM decoder does not use HighestTID nor sps_max_num_reorder_pics when bumping

Reported by: rickard Owned by:
Priority: major Milestone: HM-14.0
Component: HM Version: HM-13.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

The HM decoder is not output order conforming.

One reason is that sps_max_dec_pic_buffering_minus1 is not used for determining what pictures to output as specified in section C.5.2.2.

Another reason is HM uses sps_max_num_reorder_pics[t_id] instead of sps_max_num_reorder_pics[HighestTid] for determining whether pictures should be output.

Attachments (1)

Ticket_1261_r0.patch (3.5 KB) - added by rickard 7 years ago.
Proposed patch for ticket 1261

Download all attachments as: .zip

Change History (4)

comment:1 Changed 7 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

Changed 7 years ago by rickard

Proposed patch for ticket 1261

comment:2 Changed 7 years ago by fbossen

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r3863

comment:3 Changed 7 years ago by ksuehring

Ticket #1121 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Rickard Sjoberg(Reporter)