Opened 8 years ago

Closed 7 years ago

#1122 closed defect (fixed)

pic_output_flag and no_output_of_prior_pics_flag have no effect on the reference decoder

Reported by: jackh Owned by:
Priority: trivial Milestone: HM-14.0
Component: HM Version: HM-11.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

The reference code does not seem to discard pictures with pic_output_flag==0 or correctly handle the discard of pictures in the DPB when it encounters an IRAP picture with NoRaslOutputFlag==1 and no_output_of_prior_pics_flag==1.

Is this intended behaviour (on the grounds that it is more helpful for a reference decoder to output all decoded pictures even if they are not meant to be shown)?

Apologies if these small points appear pedantic - the reason we are interested is because at Argon Design we have made HEVC test streams, taking in all points of the spec, including the flags mentioned above.
We test by matching md5 checksums of YUV output between the reference decoder and the decoder under test, hence the discovery of this issue.

Change History (3)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 7 years ago by fbossen

The case pic_output_flag==0 should be fixed in r3840

comment:3 Changed 7 years ago by fbossen

  • Milestone set to HM-14.0
  • Resolution set to fixed
  • Status changed from new to closed

The case no_output_of_prior_pics_flag==1 should be fixed in r3847

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber, Participant)
  • Jack Haughton(Reporter)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Always)