Opened 9 years ago

Closed 8 years ago

#992 closed enhancement (fixed)

MAX_CU_SIZE (update for HM9.2 of ticket 227)

Reported by: karlsharman Owned by:
Priority: minor Milestone: HM-11.1
Component: HM Version: HM-9.2
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

MAX_CU_SIZE should be set to 6 in TComRom.h:53

If this is changed, then TComPrediction.cpp:xPredIntraPlanar:693
must be corrected:

Int leftColumn[MAX_CU_SIZE], topRow[MAX_CU_SIZE], bottomRow[MAX_CU_SIZE], rightColumn[MAX_CU_SIZE];

to

Int leftColumn[MAX_CU_SIZE+1], topRow[MAX_CU_SIZE+1], bottomRow[MAX_CU_SIZE], rightColumn[MAX_CU_SIZE];

--

In addition, the definition of g_aucIntraModeNumFast[7] should be g_aucIntraModeNumFast[MAX_CU_DEPTH] in TComRom.h:133 and TComRom.cpp:278 and 289 (and if MAX_CU_DEPTH is set to 6, the last element should be removed from their definition).

(Identified during RExt development.)

Change History (3)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 9 years ago by ksuehring

Ticket #227 has been marked as a duplicate of this ticket.

comment:3 Changed 8 years ago by fbossen

  • Milestone set to HM-11.1
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r3530

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • Karl Sharman(Reporter)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)