Opened 10 years ago

Closed 8 years ago

#227 closed enhancement (duplicate)

MAX_CU_DEPTH is 7

Reported by: chenm003 Owned by:
Priority: trivial Milestone:
Component: HM Version: HM-4.1
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

In TComRom.h, there MAX_CU_DEPTH is 7, but I guess MAX_CU_DEPTH is 6 in the draft.
Here is my patch based branch HM-4.1-dev.

diff --git a/source/Lib/TLibCommon/TComDataCU.cpp b/source/Lib/TLibCommon/TComDataCU.cpp
index 3a89a29..db3a03d 100644
--- a/source/Lib/TLibCommon/TComDataCU.cpp
+++ b/source/Lib/TLibCommon/TComDataCU.cpp
@@ -4338,8 +4338,6 @@ UInt TComDataCU::getCoefScanIdx(UInt uiAbsPartIdx, UInt uiWidth, Bool bIsLuma, B

},
{0, 1, 2, 0, 0, 1, 1, 0, 2, 2, 0, 0, 1, 1, 0, 0, 2, 2, 0, 0, 0, 1, 1, 1, 1, 0, 0, 0, 0, 2, 2, 2, 2, 0, 0, 0
},

  • {0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0
  • },

};


UInt uiCTXIdx;

diff --git a/source/Lib/TLibCommon/TComPrediction.cpp b/source/Lib/TLibCommon/TComPrediction.cpp
index dde10ca..c4f1f7b 100644
--- a/source/Lib/TLibCommon/TComPrediction.cpp
+++ b/source/Lib/TLibCommon/TComPrediction.cpp
@@ -637,7 +637,11 @@ Void TComPrediction::xPredIntraPlanar( Int* pSrc, Int srcStride, Pel* rpDst, Int

Int k, l, bottomLeft, topRight;
Int horPred;

+#if PLANAR_F483
+ Int leftColumn[MAX_CU_SIZE+1], topRow[MAX_CU_SIZE+1], bottomRow[MAX_CU_SIZE+1], rightColumn[MAX_CU_SIZE+1];
+#else

Int leftColumn[MAX_CU_SIZE], topRow[MAX_CU_SIZE], bottomRow[MAX_CU_SIZE], rightColumn[MAX_CU_SIZE];

+#endif

UInt blkSize = width;
UInt offset2D = width;
UInt shift1D = g_aucConvertToBit[ width ] + 2;

diff --git a/source/Lib/TLibCommon/TComRom.h b/source/Lib/TLibCommon/TComRom.h
index cecb457..8912380 100644
--- a/source/Lib/TLibCommon/TComRom.h
+++ b/source/Lib/TLibCommon/TComRom.h
@@ -50,7 +50,7 @@

Macros
====================================================================================================================


-#define MAX_CU_DEPTH 7 log2(LCUSize)
+#define MAX_CU_DEPTH 6
log2(LCUSize)

#define MAX_CU_SIZE (1<<(MAX_CU_DEPTH)) maximum allowable size of CU
#define MIN_PU_SIZE 4
#define MAX_NUM_SPU_W (MAX_CU_SIZE/MIN_PU_SIZE)
maximum number of SPU in horizontal line

Change History (4)

comment:1 Changed 9 years ago by davidf

Updating component after adding WD (Text) tickets

comment:2 Changed 9 years ago by davidf

  • Cc fbossen ksuehring davidf added

comment:3 Changed 9 years ago by davidf

  • Cc jct-vc@… added

comment:4 Changed 8 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #992.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • chenm003(Reporter)
  • David Flynn(Subscriber, Participant)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)