Opened 9 years ago

Closed 9 years ago

#838 closed defect (duplicate)

About vps_sub_layer_ordering_info_present_flag related syntax

Reported by: conrad.ho Owned by: bbross
Priority: minor Milestone:
Component: Text Version: D9 (K1003) v4
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

The spec said "vps_sub_layer_ordering_info_present_flag equal to 1 specifies that vps_max_dec_pic_buffering[ i ], vps_max_num_reorder_pics, and vps_max_latency_increase[ i ] are present for vps_max_sub_layers_minus1 + 1 sub-layers".

Thus the syntax is wrong.
Current:
for( i = ( vps_sub_layer_ordering_info_present_flag ? vps_max_sub_layers_minus1 : 0 ); i <= vps_max_sub_layers_minus1; i++ )
Correction:
for( i = ( vps_sub_layer_ordering_info_present_flag ? 0 : vps_max_sub_layers_minus1 ); i <= vps_max_sub_layers_minus1; i++ )

Change History (3)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 9 years ago by conrad.ho

sps counterpart had the same issue.

comment:3 Changed 9 years ago by bbross

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #862.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • Conrad Ho(Reporter, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Woo-Jin Han(Subscriber)