Opened 8 years ago

Closed 8 years ago

#862 closed defect (fixed)

7.3.2.1, 7.3.2.2, condition involving {vps,sps}_sub_layer_ordering_info_present_flag is inverted

Reported by: davidf Owned by: bbross
Priority: minor Milestone: D10
Component: Text Version: D10 (L1003) v2
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

In 7.3.2.2, seq_parameter_set_rbsp():

for( i = ( sps_sub_layer_ordering_info_present_flag ?
           sps_max_sub_layers_minus1 : 0 );
           i <= sps_max_sub_layers_minus1; i++ ) {
...
}

Will only loop once when sps_sub_layer_ordering_info_present_flag = 1.

Which has the opposite interpretation of 7.4.2.2:

sps_sub_layer_ordering_info_present_flag equal to 1 specifies that sps_max_dec_pic_buffering[ i ], sps_max_num_reorder_pics, and sps_max_latency_increase[ i ] are present for sps_max_sub_layers_minus1 + 1 sub-layers, sps_sub_layer_ordering_info_present_flag equal to 0 specifies that the values of sps_max_dec_pic_buffering[ sps_max_sub_layers_minus1 ], sps_max_num_reorder_pics[ sps_max_sub_layers_minus1 ] , and sps_max_latency_increase[ sps_max_sub_layers_minus1 ] apply to all sub-layers.

Change History (13)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 8 years ago by davidf

  • Summary changed from 7.3.2.2, condition involving sps_sub_layer_ordering_info_present_flag is inverted to 7.3.2.1, 7.3.2.2, condition involving {vps,sps}_sub_layer_ordering_info_present_flag is inverted

Same applies to vps_sub_layer_ordering_info_present_flag in 7.3.2.1

comment:3 Changed 8 years ago by davidf

Suggested new syntax:

for( i = 0; i < ( sps_sub_layer_ordering_info_present_flag ? sps_max_sublayers_minus1 + 1 : 1 ); i++ )

Suggested new semantics:

sps_sub_layer_ordering_info_present_flag equal to 1 specifies that

sps_max_dec_pic_buffering[ i ],
sps_max_num_reorder_pics[ i ], and
sps_max_latency_increase[ i ]

are present for sps_max_sub_layers_minus1 + 1 sub-layers.

sps_sub_layer_ordering_info_present_flag equal to 0 specifies that
the values of

sps_max_dec_pic_buffering[ 0 ],
sps_max_num_reorder_pics[ 0 ], and
sps_max_latency_increase[ 0 ]

apply to all sub-layers.

For VPS, s/sps/vps/g

comment:4 Changed 8 years ago by bbross

Ticket #838 has been marked as a duplicate of this ticket.

comment:5 Changed 8 years ago by bbross

  • Milestone set to D9
  • Version changed from D9 (K1003) v9 to D9 (K1003) v10

comment:6 Changed 8 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 8 years ago by bbross

  • Resolution fixed deleted
  • Status changed from closed to new

comment:8 Changed 8 years ago by ksuehring

Ticket #880 has been marked as a duplicate of this ticket.

comment:9 Changed 8 years ago by bbross

  • Version changed from D9 (K1003) v10 to D9 (K1003) v11

comment:10 Changed 8 years ago by bbross

  • Milestone D9 deleted
  • Version changed from D9 (K1003) v11 to D10 (L1003) v1

comment:11 Changed 8 years ago by bbross

  • Milestone set to D10

comment:12 Changed 8 years ago by bbross

  • Version changed from D10 (L1003) v1 to D10 (L1003) v2

comment:13 Changed 8 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • David Flynn(Reporter, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Participant, Always)
  • Woo-Jin Han(Subscriber)