Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#835 closed defect (fixed)

Invalid SPS pointer used during picture output

Reported by: bheng Owned by: ksuehring
Priority: minor Milestone: HM-9.1
Component: HM Version: HM-9.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

The xWriteOutput and xFlushOutput functions reference slice SPS pointers that may not be valid when the picture is actually output. Using these invalid SPS parameters (picCropping and numReorderPics) can cause the decoder to crash.

The attached patch attempts to store the relevant parameters with the picture itself so the SPS pointer is not used at output time.

Attachments (1)

invalid_sps_bug.patch (11.3 KB) - added by bheng 9 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

Changed 9 years ago by bheng

comment:2 Changed 9 years ago by ksuehring

  • Owner set to ksuehring
  • Status changed from new to assigned

comment:3 Changed 9 years ago by ksuehring

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in r3065

comment:4 Changed 9 years ago by ksuehring

Ticket #818 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Brian Heng(Reporter)
  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Owner, Subscriber, Participant, Always)