Opened 9 years ago

Closed 9 years ago

#818 closed defect (duplicate)

Multiple SPS with same ID

Reported by: fuldseth Owned by:
Priority: minor Milestone: HM-9.1
Component: HM Version: HM-8.1
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

Assuming that multiple SPS with the same ID are allowed by the standard, the HM decoder does not seem to work properly.

Problem description:

HM allocates a buffer containing new SPS each time it received new SPS. With the second SPS with same ID, it frees previous SPS buffer.
However, previously decoded slice is not yet output and still has its SPS buffer pointer referring to freed buffer. When this decoded slice is output (after reading slice header of next IDR), it uses corrupted SPS parameters from freed buffer then crashes.

Change History (5)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 9 years ago by ksuehring

  • Milestone changed from HM-8.1 to HM-9.1

comment:3 Changed 9 years ago by ksuehring

Could you please check if issue #835 is a duplicate of this? A patch for that has been applied in HM-9.0-dev.

comment:4 Changed 9 years ago by fuldseth

Yes, the patch for issue #835 should also fix this issue.

comment:5 Changed 9 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #835.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Arild Fuldseth(Reporter, Participant)
  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)