Opened 9 years ago

Closed 9 years ago

#807 closed defect (duplicate)

Missing clip after reconstruction

Reported by: jonharper Owned by: bbross
Priority: minor Milestone:
Component: Text Version: D9 (K1003) v4
Keywords: clip residual resSample Cc: bbross, wjhan, jct-vc@…

Description

  • According to Frank Bossen (see http://mailman.rwth-aachen.de/mailman/private/jct-vc/2011-November/002445.html), the output of the 2D 32x32 idct can be on 11 bits for a 8bit "normal" bitstream after the right shift by 20-8.
  • In JCTVC-K1003_v3, there is no clipping operation in "8.6.5 Picture construction process prior to in-loop filter process" after the reconstruction.
  • In the reference decoding software, there is a clip operation (see TDecCu.cpp line 485, 557 and 703) after the reconstruction.

I suggest a call to Clip() is added in section 8.6.5 to avoid overflows from 11 bits residuals. Without this, for corrupted or evil bitstreams, there is a mismatch between HM and D9.

Change History (2)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 9 years ago by bbross

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #687.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Woo-Jin Han(Subscriber)