Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#791 closed defect (fixed)

Encoded bit stream cause segmentation fault in decoder when using IDR in DecodingRefreshType

Reported by: xiaosong Owned by:
Priority: critical Milestone:
Component: HM Version: HM-8.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

When encoding using encoder_randomaccess_main.cfg. Only change in cfg is to use IDR for DecodingRefreshType. It seems to be related to POC calculation.

Attachments (1)

negative_poc_w_idr.patch (641 bytes) - added by bheng 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 10 years ago by ksuehring

I have updated a number of POC references to signed int, but there still seems to be an issue with a wrong reference picture.

comment:3 Changed 10 years ago by bheng

The negative POC pictures following the second IDR are never decoded because of the following if statement:

    if (m_prevPOC >= m_pocRandomAccess)
    {
      m_prevPOC = m_apcSlicePilot->getPOC();
      return true;
    }

m_pocRandomAccess is set to zero, so anything with negative POC will fail this condition. You could see if the attached patch is enough to solve the problem.

Changed 10 years ago by bheng

comment:4 Changed 9 years ago by fbossen

Patch applied in r3096
using -MAX_INT instead of -MAX_INT-1 to be consistent with other uses of "minus infinity" POC values

comment:5 Changed 9 years ago by fbossen

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 9 years ago by ksuehring

Ticket #578 has been marked as a duplicate of this ticket.

comment:7 Changed 9 years ago by ksuehring

Ticket #628 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Brian Heng(Participant)
  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)