Opened 9 years ago

Closed 9 years ago

#578 closed defect (duplicate)

IDR period of 24 results in negative POCVal

Reported by: fpach Owned by:
Priority: minor Milestone:
Component: HM Version: HM-7.0
Keywords: POCVal Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

Based on configuration encoder_randomaccess_main.cfg I am encoding a stream with an IDR period of 24 by specifying -ip 24 -dr 2 on the command line.

The resulting bitstream starts with an IDR picture followed by 16 B pictures. The next picture is an IDR picture (POCVal is reset to zero), followed by 23 B pictures, where the first seven pictures have a POCVal lower than zero. Those pictures are skipped by the decoder. The negative POCVals are correctly decoded from slice header (log2_max_pic_order_cnt_lsb_minus4=4 and pic_order_cnt_lsb from 249 to 255).

Change History (2)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 9 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #791.
Negative POC values are fine. But the pictures should not be discarded at the decoder. This has been fixed in tickt #791

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)