Opened 9 years ago

Closed 9 years ago

#628 closed defect (duplicate)

IDR decoding crashes on reference picture handling

Reported by: gvwallen Owned by:
Priority: minor Milestone:
Component: HM Version: HM-7.1
Keywords: IDR Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

When changing the following option in encoder_randomaccess_main.cfg:
DecodingRefreshType : 2 # Random Accesss 0:none, 1:CDR, 2:IDR

The encoder output is as follows:
...
POC 23 TId: 0 ( b-SLICE, nQP 36 QP 36 ) 824 bits [Y 31.7512 dB U 35.
7221 dB V 38.8283 dB] [ET 3 ] [L0 22 20 ] [L1 24 22 ] [MD5:ea7b549bff0a3f
4ed23f51c4787015a7,ce5c0eb5eedbdca19a423da76ca6340f,78d6e2cf45ed837a11fbe4b5e543
1610]
POC 32 TId: 0 ( I-SLICE, nQP 32 QP 32 ) 63304 bits [Y 34.5371 dB U 38.
2891 dB V 38.8579 dB] [ET 1 ] [L0 ] [L1 ] [MD5:7dd675682622aceb58a8d60c6b
f4c34f,5ee761cf32b5c9f89a6b16f9304150e2,070c01c0f6cfca19413c7413b2ad936b]
POC 28 TId: 0 ( B-SLICE, nQP 34 QP 34 ) 16256 bits [Y 31.4156 dB U 36.
6092 dB V 37.2534 dB] [ET 5 ] [L0 0 ] [L1 0 ] [MD5:45da0160626b684dee66e0
350f1d0942,5bd4e33ab0c4f83f6f8f87956367599d,f50f0a1a6eccaa923b39261b5ddae493]
POC 26 TId: 0 ( B-SLICE, nQP 35 QP 35 ) 8416 bits [Y 30.7287 dB U 36.
2384 dB V 37.0700 dB] [ET 5 ] [L0 -4 0 ] [L1 -4 0 ] [MD5:e7c5f6f97c9380d7
5992c3b4fcb7368c,a28f3ec26b16b74d26bd94090b9f5e11,88c770253a716fe01dc4dbe3fdff45
14]
POC 25 TId: 0 ( b-SLICE, nQP 36 QP 36 ) 2360 bits [Y 29.7619 dB U 35.
8614 dB V 36.7713 dB] [ET 4 ] [L0 -6 -4 ] [L1 -6 -4 ] [MD5:2285197ba0a12f
df719cc6ee0e6bc29f,96e1c57f1b8632b1f77c27f31086fd46,fc2019edb56f802999f8ffaeb8a3
2e21]
POC 27 TId: 0 ( b-SLICE, nQP 36 QP 36 ) 2392 bits [Y 30.3157 dB U 36.
1520 dB V 37.0221 dB] [ET 4 ] [L0 -6 -4 ] [L1 -4 0 ] [MD5:952fcdbddfe90bb
d59d2187f6a384e7a,00287140b1b218eacaa6e543d889eadc,379282acbab7bbdb95c34269de148
1ca]
POC 30 TId: 0 ( B-SLICE, nQP 35 QP 35 ) 6728 bits [Y 31.5007 dB U 37.
0231 dB V 37.3884 dB] [ET 6 ] [L0 -4 -6 ] [L1 0 -4 ] [MD5:bec5d27453f6548
cb50388df2e51e2dd,bd2c6c8d1d63b20412100f4883dd702d,d71b55a6475cf9141019af00500ac
a2e]
POC 29 TId: 0 ( b-SLICE, nQP 36 QP 36 ) 2528 bits [Y 30.5533 dB U 36.
3313 dB V 37.0537 dB] [ET 4 ] [L0 -4 -2 ] [L1 -2 0 ] [MD5:7e549af60931b1f
fc0e31bee931c5cd0,57797358d3b6149707ad38bde0c7bb1e,51dbffe830f2d30c9c4a5de241340
aac]
POC 31 TId: 0 ( b-SLICE, nQP 36 QP 36 ) 2888 bits [Y 31.3209 dB U 37.
1631 dB V 37.3709 dB] [ET 4 ] [L0 -2 -4 ] [L1 0 -2 ] [MD5:d0b745622174813
7e013ffe7b9c9bb5f,abbe22e2a468949c3c7945df3e473cb5,738702b1b086ad0c80463a5a058bc
379]
POC 40 TId: 0 ( B-SLICE, nQP 33 QP 33 ) 38312 bits [Y 33.7084 dB U 37.
7730 dB V 38.4935 dB] [ET 6 ] [L0 0 ] [L1 0 ] [MD5:8f16ab6574c2e10a4a8919
7fbb593777,8939a026ebd63d9963454995ed18cd26,497e7b35f1a14cf646017590e282f20e]
...

The decoder crashes on the TComPic* TComSlice::xGetRefPic (...) function in the picture following the IDR (i.e. picture -4)
...
POC 23 TId: 0 ( b-SLICE, QP 36 ) [DT 0.047] [L0 22 20 ] [L1 24 22 ] [MD5:ea7b
549bff0a3f4ed23f51c4787015a7,ce5c0eb5eedbdca19a423da76ca6340f,78d6e2cf45ed837a11
fbe4b5e5431610,(OK)]
POC 0 TId: 0 ( I-SLICE, QP 32 ) [DT 0.406] [L0 ] [L1 ] [MD5:7dd675682622aceb
58a8d60c6bf4c34f,5ee761cf32b5c9f89a6b16f9304150e2,070c01c0f6cfca19413c7413b2ad93
6b,(OK)]
...

This because Unsigned integers are used in several functions:
Void TAppDecTop::decode()
TComPic* TComSlice::xGetRefPic ()
Void TDecTop::executeDeblockAndAlf()

Additionally, negative POC can not be signaled:
READ_CODE(sps->getBitsForPOC(), uiCode, "pic_order_cnt_lsb");

Change History (2)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 9 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #791.
this seems to be a duplicate of #791 which was resolved

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)