Opened 9 years ago

Closed 9 years ago

#701 closed defect (duplicate)

Potential issue in HM8.0 regarding interPred

Reported by: pankaj0iit Owned by:
Priority: minor Milestone:
Component: HM Version: HM-8.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

In HM8.0,

In File: TComDataCU.cpp
In Funct: TComDataCU::xGetColMVP()

Colocated picture is selected as follows:
use coldir.

TComPic *pColPic = getSlice()->getRefPic( RefPicList(getSlice()->isInterB() ? getSlice()->getColDir() : 0), getSlice()->getColRefIdx());

As per JCTVC-J1003_d7.doc section 8.5.2.1.7
"– If slice_type is equal to B and collocated_from_l0_flag is equal to 0, the variable colPic specifies the picture that contains the collocated partition as specified by RefPicList1[ collocated_ref_idx ]."

Not sure but it seems the above mentioned code should be as follows:

TComPic *pColPic = getSlice()->getRefPic( RefPicList(getSlice()->isInterB() ? (1-getSlice()->getColDir()) : 0), getSlice()->getColRefIdx());

Change History (3)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 9 years ago by ksuehring

Looks like a duplicate of #646. Can anybody confirm that and check if the proposed fix still works?

comment:3 Changed 9 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #646.
Closing as duplicate.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)