Opened 9 years ago

Closed 8 years ago

#686 closed defect (fixed)

Difference between uiQtRootCbf and no_residual_syntax_flag

Reported by: tajime Owned by: bbross
Priority: minor Milestone: D9
Component: Text Version: D9 (K1003) v11
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

uiQtRootCbf in HM-8.0 is used as opposite meaning of no_residual_syntax_flag in the WD.

Subclause 7.3.9.1 in the WD, the following appears:

if(PredMode[x0][y0]!=MODE_INTRA && !(PartMode==PART_2Nx2N && merge_flag[x0][y0]))
 no_residual_syntax_flag
if(!no_residual_syntax_flag) {
 MaxTrafoDepth=(PredMode[x0][y0]==MODE_INTRA ? max_transform_hierarchy_depth_intra + IntraSplitFlag : max_transform_hierarchy_depth_inter)
 transform_tree( x0, y0 x0, y0, log2CbSize, 0, 0 )
}

In HM-8.0 TDecEntropy::decodeCoeff(), line 573:

 UInt uiQtRootCbf = 1;
 if( !( pcCU->getPartitionSize(uiAbsPartIdx)==SIZE_2Nx2N && pcCU->getMergeFlag( uiAbsPartIdx ) ) )
 {
  m_pcEntropyDecoderIf->parseQtRootCbf(pcCU,uiAbsPartIdx,uiDepth,uiQtRootCbf );
 }
 if(!uiQtRootCbf)
 {
  pcCU->setCbfSubParts(0,0,0,uiAbsPartIdx,uiDepth);
  pcCU->setTrIdxSubParts(0,uiAbsPartIdx,uiDepth);
#if !REMOVE_NSQT
  pcCU->setNSQTIdxSubParts(uiAbsPartIdx,uiDepth);
#endif
  return;
 }
}
xDecodeTransform(pcCU,uiLumaOffset,uiChromaOffset,uiAbsPartIdx, uiAbsPartIdx,uiDepth,uiWidth,uiHeight,0,0,bCodeDQP);

Change History (8)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 9 years ago by Parabola

I can confirm this report having discovered it independently.

In my opinion, this flag needs to be renamed in the specification to "residual_syntax_flag" -- boolean variables with negative semantics are not good style. If not present, residual_syntax_flag should be set to 1.
The condition in coding_unit() should then read: if (residual_syntax_flag) { .... transform_tree() .... }

Can this be changed to be a WD issue, not HM?

Last edited 9 years ago by Parabola (previous) (diff)

comment:3 Changed 9 years ago by ksuehring

  • Component changed from HM to Text
  • Milestone HM-8.1 deleted
  • Owner set to bbross
  • Status changed from new to assigned
  • Version changed from HM-8.0 to D9 (K1003) v9

In an offline discussion with a text editor we agreed that it would be preferable to align the text with the software because all similar flags have positive meaning and there would be no change in the context initializations need.

comment:4 Changed 9 years ago by bbross

  • Milestone set to D9
  • Version changed from D9 (K1003) v9 to D9 (K1003) v10

comment:5 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:6 Changed 9 years ago by bbross

  • Resolution fixed deleted
  • Status changed from closed to new

comment:7 Changed 9 years ago by bbross

  • Version changed from D9 (K1003) v10 to D9 (K1003) v11

comment:8 Changed 8 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in JCTVC-K1003_v13 by changing semantics according to HM and renaming no_residual_syntax_flag to rqt_root_cbf.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Participant)
  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • John Funnell(Participant)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • tajime(Reporter)