Opened 9 years ago

Closed 8 years ago

#685 closed defect (fixed)

HM8/WD mismatch for abs_mvd_greater0_flag and abs_mvd_greater1_flag ctxIdx values

Reported by: tajime Owned by: bbross
Priority: minor Milestone: D10
Component: Text Version: D10 (L1003) v2
Keywords: Cc: bbross, wjhan, jct-vc@…, dominik.wojt

Description

In HM-8.0, “198” is used for initValue of abs_mvd_greater1_flag. However, in the WD, “169” or “198” is used for initValue of abs_mvd_greater1_flag.

Table 9-19 in the WD should be changed to:
Initialization variable: 0, 1, 2, 3
initValue: 140, 169, 198, 198

HM-8.0 ContexTables.h line 232:

static const UChar 
INIT_MVD[3][NUM_MV_RES_CTX]=
{
  { 169,  198, },
  { 140,  198, }, 
  { CNU,  CNU, }, 
};

Change History (7)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 9 years ago by bbross

  • Resolution set to invalid
  • Status changed from new to closed

The init value are correct, in HM the mapping to draft values for init types 0/1/2 is:

1st row in HM8.0 ----> init type 2 in D8
2nd row in HM8.0 ----> init type 1 in D8
3rd row in HM8.0 ----> init type 0 in D8

Problem is that there are exception from that rule in HM, c.f. #712.

comment:3 Changed 8 years ago by Parabola

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version changed from D8 (J1003) d7 to D9 (K1003) v9

I think "tajime" is right and the text is incorrect in:

"High Efficiency Video Coding (HEVC) text specification" draft 9 (SoDIS) JCTVC-K1003 (version 8 - date 2012-11-07 08:19:51)

The problem is not confusion over initType rows - it is a case of respecting the ordering of ctxIdx values in Table 9.4. To agree with HM 8.2, values need to appear in the following order:

140 abs_mvd_greater0_flag initType=1
169
abs_mvd_greater0_flag initType=2
198 abs_mvd_greater1_flag initType=1
198
abs_mvd_greater1_flag initType=2

comment:4 Changed 8 years ago by bbross

Right, the first column in HM related to absGr0 and the second column related to absGr1. oO keep it consistent with other tables where all init values belonging to one init type are directly following and not interleaved, I suggest to change Table 9-4 as follows:
abs_mvd_greater0_flag | Table 9-19 | 0 | 2
abs_mvd_greater1_flag | Table 9-19 | 1 | 3

comment:5 Changed 8 years ago by bbross

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:6 Changed 8 years ago by dominik.wojt

  • Cc dominik.wojt added
  • Milestone changed from D8 to D10
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from D9 (K1003) v9 to D10 (L1003) v2

Now tables 9-4 and 9-32 are inconsistent for syntax elements abs_mvd_greater0_flag[] and abs_mvd_greater1_flag[].
Table 9-4 states that for initType==1 the initialized elements from table 9-19 are 0 and 1; for initType==2 elements 2 and 3.
Table 9-32 states that for initType==1 used elements are 0 and 2; for initType==2 elements 1 and 3.

My proposition is to adjust the table 9-4:
abs_mvd_greater0_flag | Table 9-19 | 0 | 1
abs_mvd_greater1_flag | Table 9-19 | 2 | 3

Such order would be consistent with how table 9-25 is laid out - the table is grouped by syntax element not by initType.
Care should be also taken to ensure init values in table 9-19 are correctly laid out so they are interpreted as intended.

comment:7 Changed 8 years ago by bbross

  • Resolution set to fixed
  • Status changed from reopened to closed

Please have a look at the current version including CABAC cleanup (v23). Table 9-32 does not depend on init Type anymore so it would be correct to leave it as it is and I consider this fixed in v23.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • Dominik Wójt(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • John Funnell(Participant)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • tajime(Reporter)
  • Woo-Jin Han(Subscriber)