Opened 9 years ago

Closed 9 years ago

#585 closed defect (fixed)

Mismatch between WD and HM on inter_pred_idc

Reported by: Tammy Owned by: bbross
Priority: minor Milestone: D7
Component: Text Version: D7 (I1003) d4
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

  • inter_pred_idc in the initialization process is not properly set when cabac_init_flag is equal to 1 in WD. Initialization table is changed in this ticket to have the same ctxIdx values for both initType 1 and 2.
  • inter_pred_idc in the binarization process is changed to follow the one mentioned in the meeting notes and implemented in HM.

Attachments (1)

JCTVC-I1003_d4_inter_pred_idc.zip (99.3 KB) - added by Tammy 9 years ago.
inter_pred_idc WD change

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

Changed 9 years ago by Tammy

inter_pred_idc WD change

comment:2 Changed 9 years ago by bbross

  • Milestone set to D7

From the meeting notes on JCTVC-I0125:
"Decision (Simp.): Adopt (the variation that adds a context for each depth: 1st bin depends on depth and indicates bipred, 2nd bin indicates which list and does not depend on depth)."

Last edited 9 years ago by bbross (previous) (diff)

comment:3 Changed 9 years ago by bbross

Ticket #584 has been marked as a duplicate of this ticket.

comment:4 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in JCTVC-I1003_d7.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Tammy(Reporter)
  • Woo-Jin Han(Subscriber)