Opened 9 years ago

Closed 9 years ago

#479 closed enhancement (fixed)

We do not have SP pictures / text copied from AVC is not updated.

Reported by: tktan Owned by: bbross
Priority: minor Milestone: D7
Component: Text Version: D6 (H1003) dI/dJ/dK
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

Subclause 8.1, second last paragraph of step 2.:

Editorial:
a) remove ", SP,"
b) "subclause 8.3.3" should be subclause "8.3.4"
c) add to the end of the sentence "and reference picture list combination (RefPicList2)".

i.e.
Change

– At the beginning of the decoding process for each P, SP, or B slice, the decoding process for reference picture lists construction specified in subclause 8.3.3 is invoked for derivation of reference picture list 0 (RefPicList0), and when decoding a B slice, reference picture list 1 (RefPicList1).

to

At the beginning of the decoding process for each P or B slice, the decoding process for reference picture lists construction specified in subclause 8.3.4 is invoked for derivation of reference picture list 0 (RefPicList0), and when decoding a B slice, reference picture list 1 (RefPicList1) and reference picture list combination (RefPicList2).

Subclause 8.3.4.1, third paragraph:

Editorial:
a) remove "or SP"
b) add to the end of the paragraph ", used for bi-prediction and a third RefPicList2 used for uni-prediction".

i.e.
Change

Reference pictures are addressed through reference indices as specified in subclause 8.3.2. A reference index is an index into a reference picture list. When decoding a P or SP slice, there is a single reference picture list RefPicList0. When decoding a B slice, there is a second independent reference picture list RefPicList1 in addition to RefPicList0.

to

Reference pictures are addressed through reference indices as specified in subclause 8.3.2. A reference index is an index into a reference picture list. When decoding a P slice, there is a single reference picture list RefPicList0. When decoding a B slice, there is a second independent reference picture list RefPicList1 in addition to RefPicList0, used for bi-prediction and a third RefPicList2 used for uni-prediction.

Subclause 8.3.4.1, fifth paragraph:

Editorial:
Change

When the slice is a B slice, the mapping process for reference picture lists combination in B slices is applied as specified in subclause 8.3.4.3.

to

When the slice is a B slice, RefPicList2 is derived and the mapping process to RefPicList0 and RefPicList1 is applied as specified in subclause 8.3.4.3.

Change History (4)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 9 years ago by bbross

Ticket #358 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by bbross

  • Milestone changed from WD6 to D7

List combination is removed, the reference is fixed and SP slices are removed in d7 HLS text

comment:4 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in JCTVC-I1003 d4.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • TK Tan(Reporter)
  • Woo-Jin Han(Subscriber)