Opened 9 years ago

Closed 9 years ago

#478 closed defect (fixed)

2nd & 4th "If" statement in combine list initialization is vague and not precise.

Reported by: tktan Owned by: bbross
Priority: minor Milestone: D7
Component: Text Version: D6 (H1003) dI/dJ/dK
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

The language of the 2nd and 4th "if" statement in step 3 of subclause 8.3.4.3 is vague and not precise, as it is really difficult to know what "first occurance of the reference picture" actually means.

I propose editorial to change Step 3 of Subclause 8.3.4.3 as follows:

Replace
– If the entry RefPicListL0[ refIdxL0 ] is the first occurance of the reference picture,

PredLCToPredLx[ refIdxLC ] = Pred_L0, (8 12)

.....

with
– If the element RefPicList0[ refIdxL0 ] is not in the reference picture list RefPicList2,

RefPicList2[ refIdxL2 ] = RefPicList0[ refIdxL0 ], (8 12)
PredL2ToPredLx[ refIdxL2 ] = Pred_L0,

......

And similarly, replace

– If the entry RefPicListL1[ refIdxL1 ] is the first occurance of the reference picture,

PredLCToPredLx[ refIdxLC ] = Pred_L1, (8 13)

.....

with

– If the element RefPicList1[ refIdxL1 ] is not in the reference picture list RefPicList2,

RefPicList2[ refIdxL2 ] = RefPicList1[ refIdxL1 ], (8 13)
PredL2ToPredLx[ refIdxL2 ] = Pred_L1,

......

Also note that there is a defect in the List name RefPicList0 and RefPicList1, they sometimes appear as RefPicListL0 and RefPicListL1.
I suggest that all occurances of RefPicListL0 and RefPicListL1, be replaced with RefPicList0 and RefPicList1, to be consistent with the AVC text.

While we are at it, we may as well change the following variable names....... as "LC" and "lc" are not good variables as they are used elsewhere for other tools.

PredLCToPredLx to PredL2ToPredLx
RefIdxLCToRefIdxLx to RefIdxL2ToRefIdxLx
num_ref_idx_lc_active_minus1 to num_ref_idx_l2_active_minus1
ref_pic_list_modification_flag_lc to ref_pic_list_modification_flag_l2
refIdxLC to refIdxL2 (I already used this above)
mvd_lc to mvd_l2
Pred_LC to Pred_L2
mvp_lc_flag to mvp_l2_flag
luma_weight_lc_flag to luma_weight_l2_flag
delta_luma_weight_lc to delta_luma_weight_l2
luma_offset_lc to luma_offset_l2
chroma_weight_lc_flag to chroma_weight_l2_flag
delta_chroma_weight_lc to delta_chroma_weight_l2
delta_chroma_offset_lc to delta_chroma_offset_l2

Change History (7)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 9 years ago by suzukiyos

Additionally, the following variables which use "lc" may be changed as well;

ref_idx_lc to ref_idx_l2
LcToLx to L2ToLx

And, two terms, that are "lists combination" and "list combination" are used in the WD text and their meaning is same. We would like to choose one of them. "lists combination" is probably better.

comment:3 Changed 9 years ago by tktan

Also need to add intitalization of variable refIdxLC to 0 before Step 3 of Subclause 8.3.4.3.

comment:4 Changed 9 years ago by suzukiyos

Also then, the following typos in subclause 8.3.4.3 need to be corrected.

In the last two paragraphs in 8.3.4.3 (When refIdxLC is grater/less than....), "num_com_ref_list_active_minus1" should be changed to num_ref_idx_l2_active_minus1.

comment:5 Changed 9 years ago by bbross

  • Milestone changed from WD6 to D7

Combined list was removed in d7 HLS text but the following variables should definitely be renamed:

RefPicListLx should be RefPicListx.

Furthermore, the index cIdx in RefPicListL0/1[cIdx] is very confusing because it is used for color component in most parts of the draft text. It should be replaced by rIdx.

The indexing with parentheses should be replaced with indexing by brackets.

comment:6 Changed 9 years ago by bbross

Ticket #481 has been marked as a duplicate of this ticket.

comment:7 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in JCTVC-I1003 d4.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • TK Tan(Reporter, Participant)
  • Woo-Jin Han(Subscriber)
  • Yoshinori Suzuki(Participant)