Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#468 closed defect (fixed)

Memory leak in HM6.1 decoder

Reported by: gordon Owned by:
Priority: minor Milestone: HM-6.2
Component: HM Version: HM-6.1
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

Only class D test sequences can be decoded with a 32-bit decoder, due to a memory leak. The leak seems to occur in TDecTop::xGetNewPicBuffer, where an rpcPic->create() occurs at the end of the method. This does not delete any existing buffers in the rpcPic prior to creating new ones. Inserting:
rpcPic->destroy();
prior to the create() solves the problem.

Change History (3)

comment:1 Changed 10 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 10 years ago by ksuehring

  • Milestone set to HM-6.2
  • Resolution set to fixed
  • Status changed from new to closed

The fix has been applied in r2181. Please reopen this report if this creates any problems.

comment:3 Changed 9 years ago by adeel@…

Ticket #497 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • adeel@…(Participant)
  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • gordon clare(Reporter)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)