Opened 9 years ago

Closed 9 years ago

#463 closed defect (duplicate)

Text / HM mismatch for derivation of QP in deblocking processes

Reported by: kchono Owned by: bbross
Priority: minor Milestone: WD6
Component: Text Version: D6 (H1003) dI/dJ/dK
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

The CD text misses the "0" QP setting for I_PCM regions. Instead, qPL is set equal to 0 if q0,0 is coded by I_PCM. Attachment is a suggested text that fixes the current CD text bug and aligns it with HM software. The suggested text also solves the issues in Ticket 441.

Attachments (1)

20120405-kchono.doc (66.5 KB) - added by kchono 9 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

Changed 9 years ago by kchono

comment:2 Changed 9 years ago by bbross

The fix introduces the luma/chroma QP mapping table from AVC to derive QPUV. Currently this table is missing in "8.6.1 Derivation process for quantization parameters" and should be added there to derive QPCb and QPCr. QPCb and QPCr should be used in deblocking instead. As mentioned, this relates to ticket 441.

Furthermore it solves the following items from the open issues list in the draft:

  • The variable qPL used in deblocking filter process has to be defined by, e.g. setting it to QPY.
  • The Chroma QP should be considered in chroma edge filtering instad of luma QP.

comment:3 Changed 9 years ago by bbross

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #492.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Keiichi Chono(Reporter)
  • Woo-Jin Han(Subscriber)