Opened 9 years ago

Closed 8 years ago

#288 closed defect (fixed)

Encoding crash when EntropySliceMode is set to 1 or 2

Reported by: Tammy Owned by:
Priority: minor Milestone: HM-5.2
Component: HM Version: HM-5.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

Entropy slice doesn't work in HM5 by encoder crash when EntropySliceArgument indicates actual entropy slicing within a picture. In HM4, it works correctly without error.

Change History (5)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf added

comment:2 follow-up: Changed 9 years ago by ksuehring

  • Milestone set to HM-5.1

Looks like a duplicate of #286

comment:3 in reply to: ↑ 2 Changed 9 years ago by Tammy

Replying to ksuehring:

Looks like a duplicate of #286

After applying #286 on r1763, EntropySliceMode of 1 or 2 works correctly even though the original ticket was for SliceMode.
But EntropySliceMode of 1 or 2 still have problem of decoder crash or mismatch when NumTileColumnsMinus1 is set to non-zero (e.g. 1).

comment:4 Changed 9 years ago by davidf

  • Cc jct-vc@… added

comment:5 Changed 8 years ago by ksuehring

  • Milestone changed from HM-5.1 to HM-5.2
  • Resolution set to fixed
  • Status changed from new to closed

I think that was fixed in a later release. By now we don't have entropy slices any more. The respective modes for dependent slices should work.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber, Participant)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Tammy(Reporter, Participant)