Opened 9 years ago

Closed 9 years ago

#286 closed defect (fixed)

SliceMode 2 does not work

Reported by: rickard Owned by:
Priority: minor Milestone:
Component: HM Version: HM-5.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

SliceMode=2 was broken in November last year, in HM-4.1. A ticket (#225) was created which contains a patch that solved the problem in HM-4.1. During the HM 5 work, both SliceMode=1 and SliceMode=2 got broken. The SliceMode=1 problems were fixed in HM-5.0-dev-bugfix but SliceMode=2 currently (HM-5.0-dev-misc rev 1761) does not work. The attached patch fixes the problem for FAST_BIT_EST=0 by adding 3 lines of code. However, the patch does not fix the SliceMode=2 bug when FAST_BIT_EST is set to 1 which is the HM-5 default. The patch is the same as the patch in #225 except that the changes are surrounded by "#if !FAST_BIT_EST".

Note that this ticket makes ticket #225 obsolete.

Attachments (2)

SliceMode2.patch (1.2 KB) - added by rickard 9 years ago.
Patch for SliceMode=2 when FAST_BIT_EST=0
source286.patch (10.5 KB) - added by fbossen 9 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf added

Changed 9 years ago by rickard

Patch for SliceMode=2 when FAST_BIT_EST=0

comment:2 Changed 9 years ago by ksuehring

Ticket #225 has been marked as a duplicate of this ticket.

Changed 9 years ago by fbossen

comment:3 Changed 9 years ago by fbossen

The issue is that when using CABAC one should not rely on TComBitIf::getNumberOfWrittenBits() to determine a number of bits unless the arithmetic code has been "finished" (i.e., TEncBinIf::finish() has been called). Instead TEncEntropyIf::getNumberOfWrittenBits() should be used as it will correctly take into account any number of "pending" bits (e.g., as defined by m_numBufferedBytes and m_bitsLeft in TEncBinCABAC).
The patch "source286.patch" builds on the patch previously provided for #225.

comment:4 Changed 9 years ago by fbossen

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r1767

comment:5 Changed 9 years ago by davidf

  • Cc jct-vc@… added
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber, Participant)
  • Frank Bossen(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Rickard Sjoberg(Reporter)