Opened 10 years ago

Closed 10 years ago

#225 closed defect (duplicate)

SliceMode 2 does not work in HM-4.1

Reported by: rickard Owned by:
Priority: major Milestone: HM-4.1
Component: HM Version: HM-4.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

SliceMode=2 is the slice mode that uses a byte threshold for breaking slices, it can for instance be used for creating 1500 byte slices. This mode does not work in HM-4.1 since the bitcounter is not set correctly when OL_USE_WPP=1. The attached patch fixes the problem by adding 3 lines of code.

Attachments (1)

slicemode2-fix.patch (1.2 KB) - added by rickard 10 years ago.
Patch for SliceMode=2

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by rickard

Patch for SliceMode=2

comment:1 Changed 10 years ago by rickard

Let me double-check this patch once more, there might be some additional issues here. Sorry about that.

The patch is ok. It is needed for HE coding when CABAC is used. For LC the un-patched code works.

Last edited 10 years ago by rickard (previous) (diff)

comment:2 Changed 10 years ago by davidf

  • Component set to HM

Updating component after adding WD (Text) tickets

comment:3 Changed 10 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #286.
issue #286 contains an updated version of this report

comment:4 Changed 10 years ago by davidf

  • Cc fbossen ksuehring davidf added

comment:5 Changed 10 years ago by davidf

  • Cc jct-vc@… added
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber, Participant)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Rickard Sjoberg(Reporter, Participant)