Opened 10 years ago

Closed 10 years ago

#287 closed defect (fixed)

num_reorder_frames is coded twice

Reported by: jonatan Owned by: ksuehring
Priority: minor Milestone: HM-5.1
Component: HM Version: HM-5.0
Keywords: Cc: fbossen, ksuehring, davidf, jonatan, jct-vc@…

Description

The syntax element "num_reorder_frames" has been implemented twice in the SPS (in macros MAX_DPB_AND_LATENCY and G1002_RPS)

Attachments (2)

num_reorder_frames.patch (13.2 KB) - added by ksuehring 10 years ago.
Cleanup of num_reorder_frames
num_reorder_frames_r2.patch (13.2 KB) - added by jonatan 10 years ago.
Crash fix and default value change.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf added

Changed 10 years ago by ksuehring

Cleanup of num_reorder_frames

comment:2 Changed 10 years ago by ksuehring

  • Owner set to ksuehring
  • Status changed from new to assigned

A cleanup patch has been attached to this ticket containing the following changes:

  • remove duplicate syntax element and associated variables / methods
  • allow to specify value at encoder or let the software determine required size
  • move num_reorder_frames, max_dec_frame_buffering and max_latency_increase syntax elements behind max_num_ref_pics
  • rename variables to match syntax element name num_reorder_frames
  • fix trace file strings
  • cleanups related to coding style guide

(sorry for not splitting this up)

Last edited 10 years ago by ksuehring (previous) (diff)

comment:3 Changed 10 years ago by ksuehring

  • Cc jonatan added

the patch is based on HM-5.0-dev-misc r1762

Changed 10 years ago by jonatan

Crash fix and default value change.

comment:4 Changed 10 years ago by jonatan

Thank you Karsten for providing the patch. I think it looks fine.

I added a new version of it with two minor changes:

added #if G1002_RPS around
, m_numReorderFrames ( 0)
in TComSlice.cpp to avoid crash when G1002_RPS is 0

and changed so that MaxNumberOfReorderPictures equal to -1 indicates that m_numReorderFrames shall be set to the optimal value. This way also MaxNumberOfReorderPictures equal to 0 can be explicitly tested.

comment:5 Changed 10 years ago by ksuehring

  • Resolution set to fixed
  • Status changed from assigned to closed

I have applied the patch in r1764 (HM-5.0-dev-misc) with one minor change: The configuration output text has been changed to state that -1 means automatic selection.

comment:6 Changed 10 years ago by davidf

  • Cc jct-vc@… added
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber, Participant)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • Jonatan Samuelsson(Subscriber, Participant)
  • karl.sharman@…(Always)
  • Karsten Suehring(Owner, Subscriber, Participant, Always)