Opened 10 years ago

Closed 10 years ago

#248 closed defect (duplicate)

Decoder assertion failure with LoopFilterDisable=0

Reported by: chenm003 Owned by:
Priority: major Milestone:
Component: HM Version: HM-5.0rc1
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

IntraPeriod : 8
DecodingRefreshType : 2
GOPSize : 1
Frame1 : P 1 1 0.442 0 2 1 1 -1 0
LoopFilterDisable : 0 # Turn off LF will work fine

Decoder message below


Short-term reference picture with POC = 8 is lost or not correctly decoded!
inserting lost poc : 8
copying picture 7 to 8 (9)
Assertion failed: 0, file ..\..\source\Lib\TLibCommon\TComLoopFilter.cpp, line
553

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

Change History (7)

comment:1 Changed 10 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf added

comment:2 Changed 10 years ago by chenm003

  • Summary changed from decoder crash when 2nd IDR to decoder Assertion failure with 2nd IDR and LoopFilterDisable=0

comment:3 Changed 10 years ago by chenm003

  • Summary changed from decoder Assertion failure with 2nd IDR and LoopFilterDisable=0 to Decoder assertion failure with LoopFilterDisable=0

comment:4 Changed 10 years ago by ksuehring

It seems that the picture loss detection is trying to conceal a picture that has not been lost, right? Or did you actually loose a picture?

comment:5 Changed 10 years ago by libin

I think it may be caused by the calculation of POC.
At the decoder side, the POC of IDR picture is set to be 0.
In Void TDecCavlc::parseSliceHeader()
if(rpcSlice->getNalUnitType()==NAL_UNIT_CODED_SLICE_IDR)
{
...
rpcSlice->setPOC(0);
...
}

But it seems that the encoder does not do that.

comment:6 Changed 10 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #271.
A fix for picture loss has been provided in to HM-5.0-dev-bugfix r1719 (see ticket #271). A fix for deblocking filter with lost pictures has been provided in r1720 (see ticket #272)

comment:7 Changed 10 years ago by davidf

  • Cc jct-vc@… added
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Bin Li(Participant)
  • chenm003(Reporter, Participant)
  • David Flynn(Subscriber, Participant)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)