Opened 10 years ago

Closed 10 years ago

#271 closed defect (fixed)

DecodingRefreshType=2 does not work correctly

Reported by: rickard Owned by:
Priority: minor Milestone: HM-5.1
Component: HM Version: HM-5.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

The encoder does not set POC for IDR pictures that are not the first one to 0. This happens when DecodingRefreshType is set to 2 in the config file.

Also, bumping does not work correctly for DecodingRefreshType=2.

Change History (6)

comment:1 Changed 10 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf added

comment:2 Changed 10 years ago by rickard

Fix checked in to HM-5.0-dev-bugfix (rev 1719). Ticket #237 and #248 may be related as they also use DecodingRefreshType=2

comment:3 Changed 10 years ago by ksuehring

Ticket #237 has been marked as a duplicate of this ticket.

comment:4 Changed 10 years ago by ksuehring

Ticket #248 has been marked as a duplicate of this ticket.

comment:5 Changed 10 years ago by ksuehring

  • Milestone set to HM-5.1
  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 10 years ago by davidf

  • Cc jct-vc@… added
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber, Participant)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Rickard Sjoberg(Reporter, Participant)