Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1208 closed defect (fixed)

8.4.5.1 Uses incorrect coordinate system for various syntax elements

Reported by: davidf Owned by:
Priority: minor Milestone: RExt D5
Component: RExt text Version: RExt D5 (O1005) v1
Keywords: Cc: davidf, joel, teruhiko, jct-vc@…

Description

The following elements are all defined in terms of luma coordinates in syntax/semantics:

  • transform_skip_flag
  • explicit_rdpcm_flag
  • explicit_rdpcm_dir_flag

But in 8.4.5.1 are indexed using the component dependent coordinate system (xTb0, yTb0).

Use (xTbY, yTbY + yTbOffset * SubHeightC) as appropriate.

Change History (3)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc davidf joel teruhiko jct-vc@… added

comment:2 Changed 8 years ago by davidf

  • Resolution set to fixed
  • Status changed from new to closed

Replaced common sub-expression with yTbOffsetY.

NB, the reference to §8.6.6 is correct -- it is only invoked for 4:4:4.

Fixed in v2.

comment:3 Changed 8 years ago by davidf

Ticket #1204 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Reporter, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • Joel(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Teruhiko Suzuki(Subscriber)