Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1204 closed defect (duplicate)

Inconsistent coordinates for access of explicit_rdpcm_flag and transform_skip_flag

Reported by: peterderivaz Owned by:
Priority: minor Milestone: RExt D5
Component: RExt text Version: RExt D5 (O1005) v1
Keywords: Cc: davidf, joel, teruhiko, jct-vc@…

Description

transform_skip_flag and explicit_rdpcm_flag are defined in 7.4.9.11 to have array indices in luma samples.

However, when they are used in 8.4.5.1 "General decoding process for intra blocks", they are accessed with the expression:

[ xTb0 ][ yTb0 + yTbOffset ]

which I believe will be in chroma units when cIdx>0.

Change History (3)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc davidf joel teruhiko jct-vc@… added

comment:2 Changed 8 years ago by davidf

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #1208.

comment:3 Changed 8 years ago by davidf

  • Milestone changed from RExt D6 to RExt D5
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • Joel(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Peter de Rivaz(Reporter)
  • Teruhiko Suzuki(Subscriber)