Opened 8 years ago

Closed 8 years ago

#1051 closed defect (duplicate)

Error when decoding sequences with multiple sequence parameter sets

Reported by: peterderivaz Owned by:
Priority: minor Milestone: HM-10.1
Component: HM Version: HM-10.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

In TDecCavlc::parseSPS there is code to set the global variable g_uiMaxCUDepth at the line:

g_uiMaxCUDepth = uiMaxCUDepthCorrect+g_uiAddCUDepth;

However, if a bitstream contains multiple sequence parameter sets with different values for log2_diff_max_min_coding_block_size the value for the global variable may be incorrect.

This results in the error:

Assertion uiLog2TrafoSize > pcCU->getQuadtreeTULog2MinSizeInCU(uiAbsPartIdx)' failed.`

Perhaps the global variables need to be changed when the active SPS is changed?

Change History (2)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 8 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #872.
This has already been resolved with ticket #872 in HM-10.0-dev

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Peter de Rivaz(Reporter)