Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#872 closed defect (fixed)

overwrite SPS parameters when different id SPS is decoded

Reported by: sue.naing Owned by:
Priority: minor Milestone: HM-10.1
Component: HM Version: HM-9.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

In SPS parsing of HM9.0.1, global variables are set equal to parsing data.
(e.g. g_uiMaxCUWidth, g_uiMaxCUDepth)

Therefore, SPS parameters are overwritten when different id SPS is decoded.

Change History (6)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 9 years ago by davidf

  • Milestone HM-9.1 deleted

Probable fix: move the setting of these globals to the SPS activation xDecTop::xActivateParameterSets().

comment:3 Changed 9 years ago by davidf

Before we consider this further, please can you provide a test bitstream that exercises this problem. It should require activation of both SPS, not just sending a second different SPS after the first that is never used.

comment:4 Changed 9 years ago by ksuehring

I guess that test case is easy to create. Just run the encoder twice with different settings and concatenate the bitstreams.

comment:5 Changed 9 years ago by ksuehring

  • Milestone set to HM-10.1
  • Resolution set to fixed
  • Status changed from new to closed

(hopefully) fixed in r3356

could need some double-checking and testing

comment:6 Changed 8 years ago by ksuehring

Ticket #1051 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber, Participant)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Sue Naing(Reporter)