Opened 9 years ago

Closed 9 years ago

#927 closed defect (fixed)

Mismatch HM/WD in motion vector candidate derivation

Reported by: forayr Owned by: bbross
Priority: minor Milestone:
Component: Text Version: D9 (K1003) v13
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

In 8.5.3.1.6, step 7 of candidate A derivation, the condition:
DiffPicOrderCnt( refPicListA[ refIdxA ], RefPicListX[ refIdxLX ] ) is not equal to 0
is missing before the calculation of the rescale factor.

This condition is present for the candidate B derivation, and for the temporal merge candidate derivation. It is also done in the HM for all these cases.

I suggest to modify the HM as in the joined file.

Attachments (1)

Fix rescaling condition.doc (111.5 KB) - added by forayr 9 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

Changed 9 years ago by forayr

comment:2 Changed 9 years ago by bbross

Ticket #831 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in JCTVC-L0030_v3.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • forayr(Reporter)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Woo-Jin Han(Subscriber)