Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#910 closed defect (fixed)

8.5.3.1.8 Wrong operand direction when using DiffPicOrderCnt()

Reported by: conrad.ho Owned by: bbross
Priority: minor Milestone:
Component: Text Version: D9 (K1003) v11
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

In the prior K1003 v10 spec, it said

"If PicOrderCnt( pic ) of every picture pic in every reference picture list of the current slice is less than or equal to PicOrderCntVal, mvCol, refIdxCol, and listCol are set equal to..."

Based on it, the text using DiffPicOrderCnt() should be DiffPicOrderCnt( pic, currPic ) not

DiffPicOrderCnt( currPic, pic ).

Is this a typo in v11?

Change History (5)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 9 years ago by conrad.ho

Spec v11, v12, v13:
" If DiffPicOrderCnt( currPic, pic ) is less than or equal to 0 for every picture pic in every reference picture list of the current slice, mvCol, refIdxCol, and listCol are set equal to mvLXCol[ xPCol ][ yPCol ], refIdxLXCol[ xPCol ][ yPCol ] and LX, respectively with X being the value of X this process is invoked for. "

DiffPicOrderCnt( currPic, pic ) is a typo and should be DiffPicOrderCnt( pic, currPic ) .

HM coincides with v10.

comment:3 Changed 9 years ago by yk

It is indeed a typo - will be corrected as suggested.

comment:4 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in JCTVC-L0030.

comment:5 Changed 9 years ago by bbross

Ticket #933 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • Conrad Ho(Reporter, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Woo-Jin Han(Subscriber)
  • Ye-Kui Wang(Participant)