Opened 9 years ago

Closed 8 years ago

#878 closed defect (fixed)

Mismatch between WD-9 session 8.7.2.3 and HM-9.0.1

Reported by: sue.naing Owned by:
Priority: minor Milestone: HM-9.2
Component: HM Version: HM-9.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

Mismatch between WD session 8.7.2.3 and HM (*)TComLoopFilter::xGetBoundaryStrengthSingle()

  • (1) When q0(current) is P-slice and p0(neighbour) is B-slice, p0 is used as P-slice. (L1 of p0 is not used)
  • (2) HM is getting the RefIdx of pcCUP (neighbouring block) and use pcSlice (current block) reference list to find the reference picture and then compare reference pictures. Thus this step may be incorrect. In my understanding, it should find the reference picture of the neighbouring block and not the reference index

Change History (4)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 9 years ago by ksuehring

This looks like a duplicate of ticket #785 for which the fix has been applied to HM-9.0-dev. Can you please check this branch or HM-9.1rc1 if this completely resolves all problems?

comment:3 Changed 9 years ago by sue.naing

You are right. #(2) is solved in HM-9.1rc1. My mistake!

However the issue for #(1) still seems to exist in HM-9.1

(1) When q0(current) is P-slice and p0(neighbour) is B-slice, p0 is used as P-slice. (L1 of p0 is not used)

For the case when current slice is P and neighbour is B, it doesn't consider negibour having L1 and no checking for piRefP1

comment:4 Changed 8 years ago by fbossen

  • Milestone set to HM-9.2
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r3194

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Sue Naing(Reporter, Participant)