Opened 9 years ago

Closed 8 years ago

#874 closed enhancement (fixed)

Dependent slice neighborhood cleanup

Reported by: ksuehring Owned by:
Priority: minor Milestone: HM-9.2
Component: HM Version: HM-9.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

The check for bEnforceDependentSliceRestriction in TComPattern::getPU* is not necessary for dependent slices (slice segments) after the removal of entropy slices. This code can be removed.

Change History (3)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 9 years ago by ksuehring

Ticket #798 has been marked as a duplicate of this ticket.

comment:3 Changed 8 years ago by ksuehring

  • Resolution set to fixed
  • Status changed from new to closed

the unnecessary checks have been removed in HM-9.1-dev r3129 to r3134

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Reporter, Subscriber, Participant, Always)