Opened 9 years ago

Closed 9 years ago

#798 closed defect (duplicate)

algorithm of deciding block availability doesn't work well if in a dependent slice

Reported by: kimduckyeon Owned by:
Priority: major Milestone: HM-9.0
Component: HM Version: HM-8.0
Keywords: availability, multiple slice, dependent slice Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

  if ( (bEnforceSliceRestriction && (m_pcCUAbove==NULL || m_pcCUAbove->getSlice()==NULL || m_pcCUAbove->getSCUAddr()+uiAPartUnitIdx < m_pcPic->getCU( getAddr() )->getSliceStartCU(uiCurrPartUnitIdx)))
      ||
       (bEnforceDependentSliceRestriction && (m_pcCUAbove==NULL || m_pcCUAbove->getSlice()==NULL || m_pcCUAbove->getSCUAddr()+uiAPartUnitIdx < m_pcPic->getCU( getAddr() )->getDependentSliceStartCU(uiCurrPartUnitIdx)))
      ||
       (bEnforceTileRestriction &&(m_pcCUAbove==NULL || m_pcCUAbove->getSlice()==NULL || (m_pcPic->getPicSym()->getTileIdxMap( m_pcCUAbove->getAddr() ) != m_pcPic->getPicSym()->getTileIdxMap(getAddr()))))
      )
  {
    return NULL;
  }

The function TComDataCU::getPUAbove returns NULL when the slice of current LCU is dependent slice, the slice of above LCU is dependent/independent slice and the slice of above-right LCU is independet.
It is a mismatch with the clause 6.4 in WD.

The start CU address of the slice(getSliceStartCU) is referred when deciding block availability as you can confirm in the following code.
I think that it affects to make wrong decision.

In addition, it seems that #643 ticket and this problem are caused by same reason.

It need to be correct in the view of HM stabiliy testing as well as clearing mismatch with WD.

Change History (3)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 9 years ago by ksuehring

bEnforceDependentSliceRestriction should have been named bEnforceEntropySliceRestriction. It should currently be used only for context derivation and if indeed entropy slices are enabled.

comment:3 Changed 9 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #874.
Entropy slices have been removed from the spec. Thus those neighborhood checks are no longer needed. A reminder to remove them is filed in ticket #874. I'll close this as duplicate.

Last edited 9 years ago by ksuehring (previous) (diff)
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • duckyeon kim(Reporter)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)