Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#748 closed defect (duplicate)

m_fracBits is not reset when entering a new tile

Reported by: Wenhao.Zhang Owned by:
Priority: trivial Milestone:
Component: HM Version: HM-8.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

This is a trivial bug of HM8.0 encoder.

Before encoding a new tile, all the variables of RD cabac coder are reset, except m_fracBits. It may have very very small impact on coding results, but fixing it will ensure the intention of independent tile.

it's proposed to modify
<line 69, TEncBinCoderCABAC.cpp>
Void TEncBinCABAC::start()
{

m_uiLow = 0;
m_uiRange = 510;
m_bitsLeft = 23;
m_numBufferedBytes = 0;
m_bufferedByte = 0xff;

}

to

Void TEncBinCABAC::start()
{

m_uiLow = 0;
m_uiRange = 510;
m_bitsLeft = 23;
m_numBufferedBytes = 0;
m_bufferedByte = 0xff;

#if FAST_BIT_EST

m_fracBits = 0;

#endif
}

Change History (3)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 7 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #1275.

I'm closing this as duplicate and keep the newer ticket #1275

Last edited 7 years ago by ksuehring (previous) (diff)

comment:3 Changed 7 years ago by ksuehring

Closed as duplicate of #1275.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Wenhao Zhang(Reporter)