Opened 9 years ago

Closed 9 years ago

#681 closed defect (fixed)

Potential bug in TComPrediction::motionCompensation

Reported by: libin Owned by:
Priority: minor Milestone:
Component: HM Version: HM-8.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

There are below lines in TComPrediction::motionCompensation()

if( pcCU->getSlice()->getPPS()->getUseWP())
{

xPredInterUni (pcCU, uiPartAddr, iWidth, iHeight, eRefPicList, pcYuvPred, iPartIdx, true );

}
else
{

xPredInterUni (pcCU, uiPartAddr, iWidth, iHeight, eRefPicList, pcYuvPred, iPartIdx );

}
xPredInterUni (pcCU, uiPartAddr, iWidth, iHeight, eRefPicList, pcYuvPred, iPartIdx );

I think the last xPredInterUni() is unnecessary.
This problem may be caused by removal the macro of WEIGHT_PRED.
Please refer to http://hevc.kw.bbc.co.uk/trac/changeset/1840/branches/HM-5.1-dev-cleanup/source/Lib/TLibCommon/TComPrediction.cpp for more information.
In my opinion, the line 482(474) should be removed together with WEIGHT_PRED.

Change History (2)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 9 years ago by fbossen

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r2737

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Bin Li(Reporter)
  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Always)