Opened 9 years ago

Closed 9 years ago

#680 closed defect (wontfix)

HM does not use default scale of 16 for transform_skip TUs when scaling lists are present.

Reported by: pieterkapsenberg Owned by:
Priority: minor Milestone:
Component: HM Version: HM-8.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

The text specifies:

If transform_skip_enabled is equal to 1 and SizeID is equal to 0, ScalingList[ SizeID ][ MatrixID ][ i ] is set equal to 16 for i=0..15

HM does not implement this, 4x4's are still scaled with the custom list when transform_skip_enabled is true.

Change History (5)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 9 years ago by jzxu

It was handled in TComSlice.cpp, as follows (where all entries of g_quantTSDefault4x4 are 16).
#if TS_FLAT_QUANTIZATION_MATRIX

if( m_useTransformSkip )
{

src = g_quantTSDefault4x4;

}
else
{

src = (listId<3) ? g_quantIntraDefault4x4 : g_quantInterDefault4x4;

}

#else

src = (listId<3) ? g_quantIntraDefault4x4 : g_quantInterDefault4x4;

#endif

comment:3 Changed 9 years ago by pieterkapsenberg

That code doesn't actually get called when a custom scaling list is present. So the flat 4x4 is only used when the scaling list is enabled, transform skip is enabled, and there is no scaling list data present. Not sure if that is the intended behavior.

comment:4 Changed 9 years ago by jzxu

That's correct. As described in the JCTVC-J meeting note, it was decided "changing default matrix for 4x4 TUs when TS mode is enabled", which is also reflected in the latest spec.
Thus, only the default scaling list for 4x4 TUs is changed to be flat when transform_skip_enabled is equal to 1. However, if an encoder does not want to use the default sclaing list and sends a custom list, the custom list will be used for all TUs, including transform_skip TUs.

comment:5 Changed 9 years ago by pieterkapsenberg

  • Resolution set to wontfix
  • Status changed from new to closed

Ok that is clear now thanks.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • jzxu(Participant)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Always)
  • Pieter Kapsenberg(Reporter, Participant)