Opened 9 years ago

Closed 9 years ago

#667 closed defect (fixed)

Missing initialization of combIdx in combined bi-predictive candidates

Reported by: djpark0115 Owned by: bbross
Priority: trivial Milestone: D8
Component: Text Version: D8 (J1003) d7
Keywords: combined bi-predictive candidates Cc: bbross, wjhan, jct-vc@…

Description

In 8.5.2.1.3 Derivation process for combined bi-predictive merging candidates,
initialization of combIdx to 0 is missing.

Change History (4)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 9 years ago by bbross

Ticket #704 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by bbross

Solution from #704:

"Suggestion:
When numOrigMergeCand is greater than 1 and less than MaxNumMergeCand, the variable numInputMergeCand is set to numMergeCand, the variable combIdx is set to 0, the variable combStop is set to FALSE and the following steps are repeated until combStop is equal to TRUE. "

comment:4 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Will be fixed in JCTVC-K0030_v3 (to be released)

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • djpark0115(Reporter)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Woo-Jin Han(Subscriber)