Opened 10 years ago

Closed 10 years ago

#552 closed defect (duplicate)

HM 7.0 crashes with tiles enabled

Reported by: pieterkapsenberg Owned by:
Priority: minor Milestone: HM-7.1
Component: HM Version: HM-7.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

Not entirely sure what happens, but a low_delay_main stream I created with several tiles causes an encoder crash when it runs out of bits for the slice. It appears that it is reading tile markers as CABAC data.

Attachments (2)

test_lowdelay_tiles.bin (16.9 KB) - added by pieterkapsenberg 10 years ago.
HM 7.0 stream exhibiting the bug.
552_patch.patch (1.3 KB) - added by ChristianFeldmann 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

Changed 10 years ago by pieterkapsenberg

HM 7.0 stream exhibiting the bug.

comment:2 Changed 10 years ago by ChristianFeldmann

I also have a problem with the encoding/decoding of tile markers as the reference documentation states they are coded u(v) but HM codes them as ae(v) in bypass mode.
Can you provide the encoder configuration you used? Does the crash occur in the encoder or only in the decoder? Is this the original output from the encoder or did you modify it?

comment:3 Changed 10 years ago by tkunlin

For your information, here is a command line i use to (successfully) generate a stream using tiles with the HM-7.0 encoder.

bin/TAppEncoderStatic -c cfg/encoder_intra_main.cfg -c cfg/per-sequence/Kimono.cfg -f 1 -q 37 --TileInfoPresentFlag=1 --UniformSpacingIdc=1 --TileMarkerFlag=1 --NumTileColumnsMinus1=1 --NumTileRowsMinus1=1 --TileLocationInSliceHeaderFlag=1 --LFCrossTileBoundaryFlag=1 -b 2x2_lf_on.bin

Changed 10 years ago by ChristianFeldmann

comment:4 Changed 10 years ago by ChristianFeldmann

Dear tkunlin,

the configuration that you provided successfully encodes/decodes. I was actually wondering what configuration you used to make it fail.
However I found a problem using Tiles in P- and B-Frames. When Tiles are used the decoder is not able to decode the P- or B-Frame because the encoder uses a different initialization of CABAC than the decoder does. I have attached a patch (552_pathc.patch) to this ticket. Maybe this solves your problem.

comment:5 Changed 10 years ago by ksuehring

I'm sorry, I forgot that this has been found before. This is a duplicate of issue #541

comment:6 Changed 10 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #541.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Pieter Kapsenberg(Reporter)
  • Thomas Kunlin(Participant)