Opened 11 years ago

Closed 11 years ago

#55 closed defect (fixed)

TMuC 0.7 encoder hangs up (does not crash) on specific conditions

Reported by: hao@… Owned by:
Priority: critical Milestone:
Component: HM Version:
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

TMuC 0.7 encoder hanged up when using encoder_randomaccess.cfg (random-access, high efficiency). The encoding process seems to fall in an infinite loop. We have found that the problem occurs on the following two conditions.

1) Tennis, Qp=37 (This sequence may be needed for TE10)
2) Cactus, Qp=27

At least as for (1), this problem happened on a 64-bit Windows 7 Professional platform (CPU: Core i7 930 2.8GHz, Memory: 12GB), but did not happen on a 64-bit Windows XP Professional platform (CPU: Core i7 960 3.2GHz, Memory: 12GB). For both platforms, the encoder executable is 64-bit version build with Visual C++ 2008.

Is this related to v0.7.1 fixes? Or is this a new defect?

Attachments (1)

logs-#55.zip (7.3 KB) - added by hao@… 11 years ago.
encoder logs

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by hao@…

encoder logs

comment:1 Changed 11 years ago by fbossen

My run on Cactus finished (version 0.7 on Linux). I seem to have a match with your log up to frame #98 where I have 86872 bits for PSNRs of 37.0000, 39.0230 and 41.8627.
This issue does not seem to be related to any of the fixes in 0.7.1.

comment:2 Changed 11 years ago by hao@…

Thank you for providing your information.

The differences may or may not come from this issue.
I think that bits and PSNRs can be different when we choose different compilers or different optimization options, even if TMuC does not have any defects. It is because the current TMuC encoder uses floating point arithmetics, in particular, of double precision.
I'm not sure about detail implementations of VC and gcc (or icc?), though.

comment:3 Changed 11 years ago by hao

We have verified:
(1) This situation is reproducible on the same environment.
(2) The BUGFIX50-integrated TMuC0.7 encoder can successfully encode Cactus.

Therefore this issue should come from the defect #50.

comment:4 Changed 11 years ago by fbossen

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 9 years ago by davidf

  • Component set to HM

Updating component after adding WD (Text) tickets

comment:6 Changed 9 years ago by davidf

  • Cc fbossen ksuehring davidf added

comment:7 Changed 9 years ago by davidf

  • Cc jct-vc@… added
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber, Participant)
  • Frank Bossen(Subscriber, Participant)
  • Hirofumi Aoki(Reporter, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Always)