Opened 11 years ago

Closed 11 years ago

#50 closed defect (fixed)

Encoder crash when CUsize as 32

Reported by: yyu@… Owned by: fbossen
Priority: critical Milestone:
Component: HM Version:
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

As part of TE12, we are testing CUSize=32, MaxPartitionDepth =3. However, the encoder crashes at frame no. 218 for BasketballDrive 1080p at low delay high efficiency case.

Attachments (4)

encoder_lowdelay_q22.cfg (5.2 KB) - added by anonymous 11 years ago.
log_basketballdrive_BQTerrace_lowdelay.txt (48.8 KB) - added by anonymous 11 years ago.
log_basketballdrive_BQTerrace.txt (60.7 KB) - added by anonymous 11 years ago.
encoder_randomaccess_q22.cfg (5.2 KB) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by anonymous

comment:1 Changed 11 years ago by fbossen

Is any log/trace file available?

Changed 11 years ago by anonymous

comment:2 Changed 11 years ago by yyu@…

Log file at attachment.

Changed 11 years ago by anonymous

Changed 11 years ago by anonymous

comment:3 Changed 11 years ago by yyu@…

We found another crash after frame no. 132 for BasketballDrive 1080p at Randomaccess high efficiency case.

comment:4 Changed 11 years ago by Heiner Kirchhoffer

I could not reproduce the encoder crash at frame no. 218 (using a 64 bit binary). Seems NOT to be a bug.

comment:5 Changed 11 years ago by fbossen

  • Owner set to fbossen
  • Status changed from new to accepted

I have been able to replicate the crash for the random access case on a Win32 system (compiled in Release mode). Debugging info is as follows:
First-chance exception at 0x0042b8bb in TAppEncoder.exe: 0xC0000005: Access violation reading location 0x1bb1a518.
Unhandled exception at 0x0042b8bb in TAppEncoder.exe: 0xC0000005: Access violation reading location 0x1bb1a518.
Access violation happens in TEncSIFO:: xGetInterpolatedPixelArray in the following loop:

for (filterNo=0; filterNo < NUM_SIFO_TAB[sub_pos]; filterNo++)

ipVal[filterNo] += (SIFO_FILTER[filterNo][sub_pos][filter_length * ii + jj] * (*imgY_tmp1));

The issue is the dereferencing of the imgY_tmp1 pointer.
Call stack is as follows:

TAppEncoder.exe!TEncSIFO::xGetInterpolatedPixelArray(int * out=0x0012949c, short * imgY=0x1bb14702, int x=4379823, int y=4379823, int Stride=2008, int img_width=4379823, int img_height=4379823, unsigned int sub_pos=7) Line 805 + 0x17 bytes C++

TAppEncoder.exe!TEncSIFO::xAccumulateError_B(TComPic * & rpcPic=0x04698090) Line 1351 C++

TAppEncoder.exe!TEncSIFO::ComputeFiltersAndOffsets(TComPic * & rpcPic=) Line 335 C++
TAppEncoder.exe!TEncGOP::compressGOP(int iPOCLast=136, int iNumPicRcvd=8, TComList<TComPic *> & rcListPic={...}, TComList<TComPicYuv *> & rcListPicYuvRecOut={...}, TComList<TComBitstream *> rcListBitstreamOut={...}) Line 530 C++
TAppEncoder.exe!TEncTop::encode(bool bEos=false, TComPicYuv * pcPicYuvOrg=0x00686c08, TComList<TComPicYuv *> & rcListPicYuvRecOut={...}, TComList<TComBitstream *> & rcListBitstreamOut={...}, int & iNumEncoded=) Line 224 C++
TAppEncoder.exe!TAppEncTop::encode() Line 237 C++
TAppEncoder.exe!main(int argc=, char * * argv=) Line 73 C++

This might be related to tickets #68 and #56.

comment:6 Changed 11 years ago by yyu@…

We change QuadtreeTULog2MaxSize from 6 to 5 when MaxCUsize as 32. This time, the encoder did not crash, but terminate at same place for BasketballDrive 1080p at low delay high efficiency case. The executable is built with 32 bits compiler.

comment:7 Changed 11 years ago by fbossen

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in r184

comment:8 Changed 10 years ago by davidf

  • Component set to HM

Updating component after adding WD (Text) tickets

comment:9 Changed 10 years ago by davidf

  • Cc fbossen ksuehring davidf added

comment:10 Changed 10 years ago by davidf

  • Cc jct-vc@… added
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber, Participant)
  • Frank Bossen(Owner, Subscriber, Participant)
  • Heiner Kirchhoffer(Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Always)
  • yyu@…(Reporter, Participant)