Opened 9 years ago

Closed 9 years ago

#524 closed defect (fixed)

transform issues

Reported by: bbross Owned by: bbross
Priority: major Milestone: D8
Component: Text Version: D7 (I1003) d9
Keywords: Cc: bbross, wjhan, jct-vc@…

Description (last modified by bbross)

1.
Horizontal (row) inverse transform is carried out first and then vertical (column) inverse transform. HM does the opposite – column inverse transform first and then row inverse transform. Our understanding is that the HM reflects the intended design.

2.
Core transform matrix shown 8-285 is the wrong (forward rather than inverse) transform matrix. Inverse transform matrix needs to be used instead.

3.
Decision: (editorial, not relating I0428) The DST in DIS should be described in the form of matrix multiply

4.
The column (or better row) addressing:

  • k = 1 << ( 5 – Log2( nS ) ) * i

should be changed to

  • k = ( 1 << ( 5 – Log2( nS ) ) ) * i

to ensure the right precedence.

Change History (7)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 9 years ago by mwi

re 2.
The core transform matrix is not wrong if read column-wise, not row-wise. With the index fix in #586, taking care that the matrix c is read column-wise, the equations would be ok.

re 3.
#587 is doublicating this one, sorry for not having seen it (and thanks to Benjamin for pointing that out).

Additionally, it should be made sure that the definition of the transform matrix c has spaces between the coefficients to prevent interpretation of two neighboring coefficients as a difference ('9-25', '43-57', ...). It would be nice if the negative sign would be represented by the character '-', not by a dash.
The specification of the array construction using '{ {...} {...} }' should be added to 5.9.

comment:3 Changed 9 years ago by bbross

Ticket #587 has been marked as a duplicate of this ticket.

comment:4 Changed 9 years ago by bbross

  • Description modified (diff)

comment:5 Changed 9 years ago by bbross

  • Milestone set to D8

comment:6 Changed 9 years ago by bbross

  • Version changed from D6 (H1003) dI/dJ/dK to D7 (I1003) d9

comment:7 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Transform issues are fixed in current draft JCTVC-K1003

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Reporter, Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Mathias Wien(Participant)
  • Woo-Jin Han(Subscriber)