Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#498 closed defect (fixed)

Encoder can create invalid bitstream if Frame0 has non-zero temporal_id

Reported by: ksuehring Owned by:
Priority: minor Milestone: HM-6.2
Component: HM Version: HM-6.1
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description (last modified by ksuehring)

The RPS generation process requires Frame1 to have temporal_id equal to zero so that when inserting an intra period (with automatically set temporal_id value) the repeating reference structure stays the same.

Change History (5)

comment:1 Changed 10 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 10 years ago by ksuehring

a patch has been provided by Per Wennersten and has been committed in r2195 (HM-6.1-dev)

comment:3 Changed 10 years ago by ksuehring

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 10 years ago by ksuehring

a modified solution has been checked in in r2212. There must be at least one picture with temporal_id equal to zero. It does not have to be Frame1.

Last edited 10 years ago by ksuehring (previous) (diff)

comment:5 Changed 10 years ago by ksuehring

  • Description modified (diff)
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Reporter, Subscriber, Participant, Always)