Opened 10 years ago

Closed 9 years ago

#494 closed defect (duplicate)

8.4.3.1.6 Specification of Intra_Angular (2..9, 11..25, 27..34) prediction mode

Reported by: cohen Owned by: bbross
Priority: minor Milestone:
Component: Text Version: D6 (H1003) dI/dJ/dK
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

In 8.4.3.1.6, when intraPredMode is 18, Table 8-5 sets intraPredAngle to -32. Then, after equation (8-47) is applied, (8-48) is applied because intraPredAngle is less than 0. However, (8-48) uses invAngle, and Table 8-6 does not specify invAngle for intraPredMode=18.

Similarly, suppose intraPredMode is between 11 and 17, inclusive. This is less than 18, so (8-50) is applied. Because modes 11-17 have intraPredAngle values less than zero, (8-51) is applied. However, (8-51) uses invAngle, and Table 8-6 does not contain assign invAngle values to modes 11-17.

Modifying the top row of Table 8-6 may be a solution, by changing the values

From: 2, 3, 4, 5, 6, 7, 8, 9
To: 18, 17, 16, 15, 14, 13, 12, 11

We may also want to see if this affects ticket #339.

Change History (2)

comment:1 Changed 10 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 9 years ago by bbross

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #363.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Robert Cohen(Reporter)
  • Woo-Jin Han(Subscriber)