Opened 9 years ago

Closed 9 years ago

#485 closed defect (fixed)

HM software does not cope with different values of tc / beta across slices

Reported by: pieterkapsenberg Owned by:
Priority: minor Milestone: HM-9.1
Component: HM Version: HM-9.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

Like AVC, HEVC can deblock accross slices, and the two slices can have different values for beta_offset_div2 and tc_offset_div2. HM will have to take care to use the value from the slice containing the pixel q0.

Attachments (1)

deblocking_parameter.patch (8.6 KB) - added by ksuehring 9 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 9 years ago by ksuehring

Ticket #562 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by pieterkapsenberg

  • Summary changed from HM software does not cope with different values of tc / beta accross slices to HM software does not cope with different values of tc / beta across slices
  • Version changed from HM-6.1 to HM-9.0

Changed 9 years ago by ksuehring

comment:4 Changed 9 years ago by ksuehring

I have implemented a patch that directly accesses the slice data when filtering. If parameters are codes only in PPS these should still be set properly in slice data.

Please review, especially if I managed to always use the correct CTU for parameter derivation.

comment:5 Changed 9 years ago by ksuehring

  • Milestone set to HM-9.1
  • Resolution set to fixed
  • Status changed from new to closed

After positive email feedback on the patch, it was applied in r3095

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Pieter Kapsenberg(Reporter, Participant)